geomagic touch(1)(1)(1)

Geomagic OpenHaptics 工具套件


将 3D Touch 导航和力反馈设备添加到应用程序

为客户打造超凡的用户体验:使用户能够不拘泥于在应用中使用 2D 鼠标,以真实直观的方式与对象交互并进行操作。用户可以在虚拟 3D 场景中感受对象,这样便于掌握技能。为客户提供真正的 3D 导航和直接互动,提高效率,为应用程序增添令人惊艳的亮点。


OpenHaptics 开发人员版本使软件开发人员可以将力反馈设备和真正的 3D 导航添加到广泛的应用,包括 3D 设计和建模、医疗、游戏、娱乐、可视化和模拟。这款力反馈工具套件继承了 OpenGL API,便于图形程序员熟练掌握,促进与 OpenGL 应用程序的集成。 通过使用 OpenHaptics 工具套件,开发人员可以利用现有的 OpenGL 代码来指定几何形状,并通过 OpenHaptics 命令加以补充,以模拟触觉材料诸如摩擦和刚度等方面的属性。


可扩展架构使开发人员能够添加支持新类型形状的功能。它还致力于集成第三方库,如物理/动力学和碰撞检测引擎。OpenHaptics 工具套件支持一系列 3D Systems PHANTOM设备,其中包括低成本的 Touch 3D 触控设备和大型 PHANTOM Premium 设备。OpenHaptics 工具套件支持 Microsoft Windows7 和 8,以及 Linux。


3DSystems-Software-Open-Haptics-Dual-Touch-Image.jpg


OpenHaptics v3.0 功能

Linux 支持,包括对 7 DOF 选项、夹点和定制夹具的支持 - OpenHaptics 现可为大多数常见的 Linux 发行版提供支持和安装程序,例如最新版本的 OpenSuse、Fedora 和 Ubuntu。提供 RPM、DEBIAN 和 TGZ 软件包,便于各种 linux 发行版安装。使用 OpenHaptics 开发要求 7DOF 位置感知的 Linux 应用程序。使用 Sensable 的可互换式卡扣终端执行器或为 6DOF Phantom 设计自己的自定义手柄。


Windows 7 支持 - 在运行 Windows 7 的最新计算机上使用 OpenHaptics,或继续运行 XP。

  • 穿透深度 - 连续监测表面接触点的穿透深度,并相应地设置不同的力参数。十分适用于模拟,例如膜外注射,可模仿针穿过不同组织层的感觉。

  • 支持标准 3D 模型文件格式 - 在单一命令下加载包含纹理的 3D 模型。

  • 支持 3DS、OBJ、STL 和 PLY,无需在编程之前将 3D 模型转换为特殊格式。

  • 调整 6DOF 设备上的转矩参数 - 对万向节上的上下翻动、左右晃动和侧向移动的转矩参数进行单独调整。

  • 新演示和源代码示例 - 使用新的演示和示例来着手应用程序开发,了解如何:

  • 将 QuickHaptics 与较低级别的 OpenHaptics 集成;使用力反馈设备将医疗工具置于正确的位置

  • 定义自己的力模型

  • 根据穿透深度设置不同的材料属性。

  • OpenHaptics v3.0 可用于 Microsoft Windows 32 位和 64 位 XP 和 Vista,以及 Linux。

有关详情,请参阅系统要求。

OpenHaptics 工具套件支持一系列受支持的 Sensable PHANTOM 设备,其中包括低成本的 Phantom Omni 设备和大型 Phantom Premiums 以及 Premium 6DOF 设备。


OpenHaptics v3.0 for win32 和 x64 Windows 7、Vista 和 XP

硬件

  • Dual Xeon® Pentium® IV 2.4 GHz 或更好的处理器或更高版本

  • 512 MB 可用磁盘空间

  • 2 GB RAM

  • 根据 PHANTOM 型号:并行端口(内置于主板或 Axxon 并行适配卡的 EPPMode 端口推荐使用)或 FireWire 1394a* 或 10/100Mbps 兼容的以太网适配器

笔记本电脑

  • 尚未在笔记本电脑上对接口进行完全测试

  • 一般情况下,PCMCIA 卡比 Express 卡连接性更好

  • 无论选择哪种卡,都请确保按照制造商的说明使用最新的驱动程序。

  • 软件:Windows® XP-32 (SP3)、XP-64 (SP2)、Vista-32 (SP2)、Vista-64 (SP2) 或 Windows 7(win32 或 x64)

  • 编译器:Microsoft® Visual C++ 2005 (SP2) 或 Visual C++; 2008 或 Visual C++ 2010

  • 可能需要重新编译 HDU 和 HLU 实用程序库

  • 驱动程序:PHANTOM 设备驱动程序 v5.1.7 或更高版本

  • 一种支持的 PHANTOM 力反馈设备。请注意,不支持基于 PCI 的 PHANTOM Premium 设备。

  • PHANTOM Omni (FireWire IEEE 1394a)*

  • PHANTOM Desktop(并行端口或 LAN 端口)

  • PHANTOM Premium 1.0、1.5、1.5 High Force、3.0(并行端口或 LAN 端口)

  • PHANTOM Premium 1.5/6DOF、1.5HF/6DOF、3.0/6DOF(并行端口)

  • 注意:PHANTOM 通信转换器 (PCC) 可用于与 FireWire 接口一起使用的并行端口设备。


OpenHaptics v3.0 for Linux

硬件

  • Dual Xeon® Pentium® IV 2.4 GHz 或更好的处理器或更高版本。要与 Sensable Desktop 或 Premium 设备连接,需要使用内置在主板中的 EPP 模式并行端口。

  • 512 MB 磁盘空间和 2 GB RAM。

软件

  • Ubuntu 11.1 和 Fedora 16(或更高版本)

  • 核心 3.3.0 或更高版本

  • Mesa-OpenGL® 使用 GLX 接口访问 X Window System®。确保在您的系统上运行 "glxgears"

  • GLUT-OpenGL 实用工具包

  • MesaGLw-Mesa 小部件库。要求 Motif 绑定(使用 ./configure--enable-motif 构建)

  • FreeType2-Portable 字体引擎 (http://www.freetype.org)

  • 编译器:gcc 4.x

  • 驱动程序:PHANTOM 设备驱动程序 v 4.3-2* 或更高版本

* 在终端找到内核版本类型 "uname -r"。有关其他问题,请查看开发人员支持中心的在线文档 (http://dsc.sensable.com) 或将问题发送到开发人员论坛。

支持的 PHANTOM 型号之一。

  • PHANTOM Omni (FireWire IEEE 1394a)*

  • PHANTOM Desktop(并行端口)

  • PHANTOM Premium 1.0、1.5、3.0(并行端口)

  • PHANTOM Premium 1.5/6DOF、3.0/6DOF(并行端口)

请注意,不支持以下配置:

  • High Force PHANTOM Premium 设备

  • PHANTOM 通信转换器

  • 双 PHANTOM 配置

  • 基于 PCI 的 PHANTOM Premium 设备

* PHANTOM Omni 设备与 IEEE 1394a 兼容。但是,Sensable 发现,将控制器卡与特定 IEEE 1394a 芯片或驱动程序组合结合使用时,客户会遇到 PHANTOM 设备性能问题。在这种情况下,可能需要更新或更改 1394 控制器卡驱动程序或尝试使用单独的附加 1394 控制器卡。


要正确操作和控制触觉伺服环路,需要主机有足够的“实时”性能。在 Windows 下,要测量计算机上的系统延迟,请使用 TheSyCon 网站提供的 DPC 延迟检查器。如果红条出现的频率一般高于 5-7 秒,请考虑更新 BIOS、芯片固件、系统设备或其他设备驱动程序。


如果与 PHANTOM 设备的 FireWire 或 Parallel 通信挂起或不一致、间歇性中断,或者整个操作系统已从 XP 升级到 Windows 7,则此类低级系统也会进行更新。

Copyright @2019 北京舜若科技有限公司 Sunya Technologies, Ltd.



企业公众号
会员登录
登录
其他帐号登录:
我的资料
留言
回到顶部